Unitron Remote Plus app on iPhone or Android

The minimum requirements for smartphones:    

  • iOS version 10.2 and Bluetooth version 4.2 or newer

  • Android version 6.0 and Bluetooth version 4.2 or newer.

Download the, “Remote Plus” app from the Apple App store, or Google Play store. Follow the onscreen instructions to connect your hearing aids.

-To stream audio signal you will still need to follow the iPhone or Android pairing instructions to connect your hearing aids within your phones Bluetooth menu.

Android:


iPhone:

Need additional help? TeleSupport is available Monday to Friday 9am - 7pm EST by:
- Chat: Located on the bottom right of the page
- Email: telesupport@hearingaidhelp.ca
- Phone: 1-833-TELESUP (835-3787)

Did you find it helpful? Yes No

Send feedback
Sorry we couldn't be helpful. Help us improve this article with your feedback.